Aiper Community

Loading...

Register
section-icon

Forums

Talk about anything you want!

Welcome To

Aiper Seagull Pro mode knob stuck/electrical

Viewing 15 reply threads
  • Author
    Posts
    • Bought our Seagull Pro last June. About a month after the mode knob started getting stuck… we have to make several tries and wiggles to make it move.

      And to make matters worst… this week we noticed a burnt smell, went to see what it was… the charging cable tip literaly got fused with the charging port.

      Opened a claim with Aiper.

      Waiting to see how it will be handled

    • Good day I have the same problem, to the extend that I am afraid to brake the knob while I am trying to start the cleaning.

       

      I may have to contact wiper and return the product since it still is under warranty.

       

       

       

       

    • Hi guys,

       

      Especially with the smoke, please stop using the product immediately. Please contact Service@aipervip.com with your issues. Our VIP line is quicker to respond to your problems.

       

      Thank you.

    • I am having the same issue with mine. After charging it the knob gets stuck and is hard to turn in any direction. I wrote Aiper and they say it sounds like sand in the switch. I asked for something to show me how to disassemble this thing and a get a short video on the switch. I need to know how to I even get to the switch? After reading lots of others have the same issue Im thinking its no sand.

    • I too am now having the same issue with the switch very difficult to turn.
      this seems to be not an isolated incident. Please advise what to do next.

    • Seagull Pro user here and I cannot rotate the mode selector switch. Afraid if I turn too hard I will break it. Please advise on what I should do.

      1 user thanked author for this post.
    • Stuck Knob Update!

      I was able to turn it after putting it in the pool first (not sure if this helps), press down a bit on the dial, and then turn. At first, it will refuse to budge but if you keep downward pressure along with turning pressure (not too much, just enough to feel resistance) it will activate. It works but something is not right for sure.

      1 user thanked author for this post.
    • I had the problem where getting the knob out of the Off position took a ridiculous amount of force. I came up with a solution after being told it was “sand in the knob” and replacing the unit once for this problem. After using, plug it in for charging and SLOWLY turn the know until the charging light on the knob ring appears. This position is just short of the completely Off position but is in effect turning it off. It is a bit of trial and error to find the sweet spot but this solved my problem.

      1 user thanked author for this post.
    • I’m happy to report that Aiper took care of us.

      They sent a brand new unit to us and a label to send the defective unit back.

      its winter here in Massachusetts so haven’t tried the new unit… but at least when it comes to customer service I can only give a 5 start rating.

    • I have the same issue.  Started getting hard to turn after about 3-4 uses.  Getting exceedingly harder – today I didn’t think I could turn the knob at all.
      As I above – having to apply a ridiculous amount of force to get the know out of the OFF position. 🙁 

    • I am having the same problem with the knob. It almost feels like there is an inherent locking mechanism because many times i have just removed my hand from the knob, waited a few seconds, then it works. Has anyone been game to try and remove the knob for an inspection? If so, how did you do it?

      • Hi Trevor – I had been meant to get back on this site…  I got the troubleshooting assistance from Aiper – seems to have worked (but i haven’t used it since i resolved the issue i must say)….
        It is due to small particles getting in under the knob, which makes sense i guess when i look at the very fine particles the Seagull catches from the pool….
        1-Pressure Wash / Water around the knob
        2-WD40 around the knob
        I had actually been going to try the wd40 but wasn’t game… just incase.  It appears to have worked a treat.

    • This was the main message from Aiper Support (which so far has worked for me)…
      Quote…
      1. Is your pool a saltwater pool? If so, it may be saltwater crystals or other obstructions stuck. Please use a high-pressure water gun to clean the switch and then try again.

      2. Please add lubricant to the gap of the switch knob to try. If it works, try it again after cleaning the residual lubricant.

    • Thanks Megan. I have received the same messages and service from Aiper that you did, but haven’t got a fix yet

    • There is enough of a gap between the knob and the body to apply a good dose of WD40, which has fixed my sticky knob completely.

      • Great news… I was worried coz there wasn’t really much of a gap at all – but i guess it doesn’t need much for the WD40 🙂

        Sharon from Aiper also followed up with…

        Here are some maintenance tips for your reference.
        1. After your last use of your Aiper device for the season, thoroughly clean the machine of any residual dirt, including the top & bottom shell, wheels, roller brushes, and charging port, then dry your device by wiping it with a cloth or paper towel.
        2. On the Seagull Pro, it’s important to clean the knobs, switches, and drive shaft area with fresh water to avoid water residue from affecting the device’s hardware and saltwater crystallization during storage.
        3. We recommend adding protection to your machine and boxing and storing it indoors in a cool place to prevent scratching, accidental damage, and dust accumulation.
        4. The last and most important tip in maintaining your device is to charge it every three months to 40%-60% to maintain battery health. If your device sits idle for too long without being charged, you may experience unintentional, potentially harmful battery discharge and battery voltage issues.
        If you need any assistance, please feel free to contact us.
        Best regards,
        Sharon
        Aiper Customer Support

    • My knob is also hard to turn, but using both hands, once it’s past the “click” it turns freely.  Hard to turn every time. I’ll try a little wd-40.

    • My knob is also hard to turn, but using both hands, once it’s past the “click” it turns freely.  Hard to turn every time. I’ll try a little wd-40.

      The WD40 worked!  Much easier to turn now, can use 2 fingers instead of 2 hands!

10

Voices

19

Replies

Viewing 15 reply threads
  • You must be logged in to reply to this topic.