Aiper Community

Loading...

Register
section-icon

Forums

Talk about anything you want!

Welcome To

Seagull Pro Not Charging

Viewing 15 reply threads
  • Author
    Posts
    • I have had the Seagull Pro for a few weeks, and it has been great so far. This weekend, I plugged it in to charge, and it will not charge. The indicator on the charger brick is green, and the light around the ring does not turn on when plugged in (to indicate it is charging). Any thoughts?

    • Hi,

      First off, I apologize that you’re having difficulties. Can you tell me some of the ways you’ve tried to troubleshoot your charging issue so far? Knowing this will help me eliminate any possible problems you may be having. This sounds like there may be an issue with the charging pins, please ensure the charging port is completely dry before charging as a wet charging port can interfere with the Pro’s ability to charge.

      After you’ve let me know some of your ways you’ve tried to troubleshoot this, I’ll get back to you with some additional information.

    • Hey,

       

      Wanted to followup with you. I looked into some possible issues you may be experiencing with your PRO and the most likely scenario is that water has flooded a system it shouldn’t have. You’ll need to contact customer service for a replacement.

       

      We apologize for your issue and I hope customer service takes care of you soon.

       

    • Thanks. I didn’t really have any way of troubleshooting or trying to solve it myself (besides plugging it into a different outlet). I will contact support.

    • i have the same issue… green light is on but it wont charge the aiper…. give me a phone number to call service and where i can deliver this thing to because now it is just a big weight.

    • it seems mr aiper official that this is a problem with many people… why dont you have a recall…. send us all a new aiper  cause this is not the first time we have had this problem…

      2 users thanked author for this post.
      • I have had two of these and both failed the same way.  Charging pin on the robot corroded and broke off.  Two of the same unit with the exact same problem.  One lasted less than a year and the other a little longer.  Very bad design.

    • It was too good to be true.  Worked great for about 6-7 months and now won’t charge.  Frustrating!

    • Same issue, charging block is green, no charge. Please advise how we get this repaired.

    • I have same issue….turns out one of the charging pins broke off and won’t charge. I can’t get any help because I don’t have the order number but yet I have an account and receive weekly emails from Aiper.  this thing isn’t 2 years old and it’s a paper weight

       

    • Having the same issue!

      Worked great last year, but will not charge even with green light!

      Frustrating!

      Lots of advertising on Facebook but not answers or help with problems!

    • Having the same issue.  Worked great for 6 months.  Not charging.  I tried unplugging it overnight and still not charging.  Has anybody had this issue resolved with Aiper?

    • Same problem, mine is now 10 months old and seems we have always had a problem getting it to start charging, now nothing at all.  I contacted service@aiper.com and they tell me it is a problem with the motor, I think it is the battery, bad to begin with, but what do I know.  They want to send me a refurbished one to replace it.  Not real keen on that since I bought a brand new one to begin with, why don’t I get a brand new one to replace a dysfunctional one?  I do have to say that customer service has been quick to reply, I started the email conversation on a Saturday since their offices were closed and I could not talk to anyone on the phone.

      • Just had a thought here, did we all buy ours in May 2023, and from Amazon?  If the majority did, seems to be a bad batch.  Aiper needs to make this right!

    • Purchased mine June 2023. No problems until about a month ago. Beeps when plugged in then color indicator stops flashing or lighting up, then goes dark. No charge, even though block is green. Very frustrating. Aiper doing anything about this?

      • Aiper has resolved my issue by exchanging the broke one with a new one, should be getting it today!  They tried to replace it with a refurbished one but you know, I didn’t buy a refurbished one so why should I settle for a refurbished one.  They were very prompt, helpful, and understanding.  I am satisfied with the results.

        You must reach out to their service department to get it resolved and they seem to be accommodating about this issue.  I reached out to service@aiper.com on Saturday (3/31) and here is it Friday (4/5) and I should be getting my replacement anytime now. 

    • My seagull Pro worked great for about 3 months… No it will not run at all…

       

      It charges, light is green, I drop it in the pool. Some bubbles come out and then it just sits on the bottom… Occasionally it runs a few feet, but for the hundreds I spent for this product, it is a waste unless there is a fix to the problem

       

      Randy

    • Update on my issue.  They sent a refurbished unit and immediately I knew it wasn’t going to charge.  Sure enough, nothing.  Beeped, lit up, then goes dark.  I reached out again and they’re sending a new unit.  Don’t know much about the mechanics/electronics, but I have a feeling the issue is the charger, not the unit itself.  Really hope this new one does the trick….  super expensive!  But, it worked really great so didn’t mind the cost.  Fingers crossed!

    • Update on my issue…I received the new replacement and oh what a difference!  I am convinced now that the one I originally bought and received was a refurbished one, not a new one as I was led to believe.  The plug on the new replacement fits so much tighter, it charges and runs perfectly, the rubber plug cap is sturdier, the power knob is smoother, and it was even packaged different/better.  There was a big difference in everything about what I originally received and the replacement.  Thank you Aiper for eventually making it right, but I think you are trying to dupe people with used/refurbished products. Not cool, and a big headache for everyone.

12

Voices

18

Replies

Viewing 15 reply threads
  • You must be logged in to reply to this topic.