Aiper Community

Loading...

Register
section-icon

Forums

Talk about anything you want!

Welcome To

Seagull Pro stuck mode selector dial

Viewing 23 reply threads
  • Author
    Posts
    • Hello, I would appreciate some help. The mode selector dial is stuck in the off position. I’ve only had my unit for 6 weeks. I last used it 6 days ago. It is fully charged. Over the past few weeks I noticed it would slightly stick in the off position a few times and I would have to apply a little more torque than usual but once freed up it would rotate normally through all mode positions. Now it’s really stuck in place and I can’t get it to rotate at all.  The FAQ insert in my manual mentions this problem where debris might be stuck around the selector dial and to try using a hose or pressure washer to dislodge it. I tried and no luck. I don’t see evidence of debris. The plastic piece that normally rotates around the circumference of the selector seems to jiggle slightly so it doesn’t appear to be stuck however whatever it is supposed to move inside the assembly is seized somehow. Anyone else have this problem? What’s the fix? Thanks!

    • Hi Josh,

       

      I can’t say i’ve ever heard of this issue before. If you could email me a short video that would be great. Jason@aiper.com

      • Ihave the exact same issue.  I go back and try it an hour later, it kind of pops and then turns.  Right now it is stuck again.  This happens everytime.  Any solution yet?

      • Any help on this!!! I have my second unit and it is doing it again?

      • Any help on this!!! I have my second unit and it is doing it again? yes but you have not solved the issue

    • I am returning mine before the no return date, due to this issue and no response

    • 4 users thanked author for this post.
    • I mailed my robot back to them under warranty. I’m waiting for them to mail me the replacement.

    • Good news for me, i bought it via Amazon and am returning it since Aiper does not seem to be able to help.  I might try one more, but I will stick with Amazon since I have time to return it if the same issue shows up.  Other than this issue it works great for me.  But if I can’t get it to turn on, it is just a boat anchor.

       

      2 users thanked author for this post.
    • I was having the same issue with the Seagull Pro, Selector Dial would not turn.  The last time it was locked and after 3-4 minutes, would not turn at all.

      I found if I turned the drive wheels slowly by hand while turning the selector knob, it would pop in.  Then I could turn to any setting.

      Also, what I have also found is that I never use the Automatic setting, since I have a 40′ X 20′ in-ground, it would never finish the walls after cleaning the floor.  So I clean the floor one day, and the walls the next.

      Again, this is how am I using the Seagull Pro.  Hope this helps.

      1 user thanked author for this post.
    • Hello everyone,

       

      We’re sorry that you had to make your way here to resolve the issue, which we’re working with our R&D team to correct as soon as possible. In the mean time, we suggest contacting our VIP customer service team at service@aipervip.com to resolve the issue as a priority. Please include your order number and a video of the issue so we can fix this as soon as possible.

      1 user thanked author for this post.
    • Mine is new. Used 3x and doing the same.

    • Everyone, I think I figured it out.  Mine gets stuck, I turn it on it’s side or upside down and the selector turns.  Must be something blocking, turning it over seems to work everytime so fare

      2 users thanked author for this post.
      • Just did the same and it worked. Frustrating!!!

      • I tilted it forward and it worked. Must be something inside that gravity causes it block it.  Thanks for the help.

    • Mine gets stuck, too, but I’ve been able to force it after a few tries.  I also have the wheelie problem so I’m going to return it. How long has this model been out? Is this just a new problem?  Maybe they should have a recall on the latest batch of Seagull Pros.

    • Mine gets stuck, too, but I’ve been able to force it after a few tries.  I also have the wheelie problem so I’m going to return it. How long has this model been out? Is this just a new problem?  Maybe they should have a recall on the latest batch of Seagull Pros.

      The Seagull Pro was released earlier this year. The recurring issue with the dial some users have been experiencing lately is a recent development and affects a very small percentage of Seagull Pro owners.  We’re working with both R&D and manufacturing to see what is the cause and solution to this issue, in the meantime, we encourage anyone who hasn’t tried the suggested fixes to contact customer service.

      • Let R&D know it must be something dropping down due to gravity because Larry’s trick works.

    • I received my Seagull Pro in late June and have used it almost every day as we have lots of leaves from trees. It works great and am very pleased with it’s performance. Lately the selector knob has been getting hard to turn off and on. I have to wrap a towel around the knob and apply as much torque as I can muster. After several attempts I get it to turn. I just read about the turning it over or rotating the wheels. Would Like to know if there is a permanent fix for this problem. thanks.

    • I am having the same problem. I’ve had the unit for less than 8 weeks. Very frustrating.

    • You would think the company could figure this out by now.  Something must be loose in the switch or it is getting something like fine dirt that is making it stick.  Let’s how thee turning upside down keeps working

    • I have the same issue with my Seagull Pro. The dial is getting stuck and I can’t turn it off.

    • The dial got stuck with me as well, and I did as recommended in the chat by tilting the Aiper, then the knob worked. Thank you

    • I tried all the tricks – worked a few times. Now it’s frozen again and I actually tore my hand open trying to turn the dial. Extremely disappointed in this product and the response from the company to try what we are crowdsourcing rather than their RD folks figuring this out.

    • avatar-image

      Pete

      @pete

      Participant

      The company set me a new selector switch the only thing is no directions on how to install it. Please send directions or post a video on this site. Thanks

    • I have the same issue like everyone on this chat.

      My unit is a couple of months old.

    • Purchased the AIPER Seagull Pro Cordless Robotic Pool Cleaner, and have the same issue of the button being stuck and won’t turn. I laid it on it’s side, gave it a few good bumps, and it turned on. Should not happen.

      • I have the same issue as well, have emailed service@aiper.com for the warranty return and refund process. Tried all the suggestions, wont work at all. Not good enough.

        Regards

        Rob Mitchell – Queensland Australia

        P.S. Warning to potential buyers, do not purchase a Aiper product, as per the Aiper community chat, they have been aware of this issue since July 2023 but have continued to sell faulty equipment. I purchased mine in late December 2023, lasted 2 months only.

    • avatar-image

      Al

      @bigal

      Participant

      Yes, I too have the same problem. My seagull pro is only 3weeks old, today when I went to take it off the charger and pop it into the pool, the mode selector dial was locked in the ‘off’ position. No matter how hard I tried, I couldn’t turn it.
      it wasn’t until I found this thread online , that I found what seems to be a temporary fix; turn the unit on its side. The dial then turns.
      Quite odd.

       

      1 user thanked author for this post.
      • We have the same issue the the dial being stuck in off position.  I have emailed Aiper and, so far, I can’t fault their customer service!  They have emailed me with questions, which we’ve answered.  They’ve now said, due to  information we supplied (we only supplied the S/N so thinking maybe a bad batch?) it needs to be replaced and they will create a return label for us.  Unfortunately there aren’t any available until April so we’ll have to wait until then.  I’m happy that they’ve acknowledged every email I’ve sent and within a perfectly good time frame considering they’re in the US.

        1 user thanked author for this post.
    • Same issue with mine! Only had it for a month. Used half dozen times and just dial just stopped stuck. Have emailed them and hopefully resolve issue fast.

    • Following a reply message from Aiper, I have spray around my dial with a silicon lubricant, worked perfectly, no problem since. Shouldn’t have to do it but it’s working now and I don’t want to be messed around with no robot during the return process. Happy with unit now.

Viewing 23 reply threads
  • You must be logged in to reply to this topic.